Sorry 'bout the performance issues lately.  Chad and the gang are looking into why my tummy started acting up again.

In the meantime apologies for the getting stuck sometimes, the icky performance and what not.

with 1 comment(s)
Filed under:

Thanks to Robert of  Interscape Technologies the blog site of msmvps.com has anew "skin" and a new look. 

Check it out!  I think it makes it look pretty spiffy!

with 1 comment(s)
Filed under:

It's annoying when something was working nicely for a while and then you make a change (a Service pack to the blog platform) and then we go back to being choppy performance again.

This morning I woke up to a message that the blog had been offline for about two hours and when I logged on the web sites wouldn't manually recycle so I had to reboot the box.

Bear with us as we get it back to stable.

with no comments
Filed under:

Yoda here, checking in after Chad (the great the wonderful, the one who knows what he's doing) upgraded me to the latest Community Server

My tummy now says:  Your version: 4.1.40407.4157

I've also had them put back in the YouTube module and the issue where we want to turn back on the indexing

 

CS08 introduced a features which allows you to define if pages should be allowed to be indexed in their entry in siteurls.config, the aim of which is to prevent google indexing duplicate content.  This however can fall foul in certain situations and you may wish to turn that off.  The way to do that is to opensiteurls.config, and do a find and replace replacing all instances of

indexable="false"

with

indexable="true"

 

To do a fix of the database to get it ready for the update to CS 2008.

Apologies for the inconvenience.

The blogs may be off up to 8 hours.

with 2 comment(s)
Filed under:

The ALTER TABLE statement conflicted with the FOREIGN KEY constraint "FK_cs_Referrals_cs_Urls". The conflict occurred in database "msmvps-cs", table "dbo.cs_Urls", column 'UrlID'.

Rolled back to CS 2007 as hitting an error in the upgrade.  Will hire someone to do this upgrade.

To upgrade to CS 2008. To ensure I have a good backup, shutting off the web site.

Be back.

I may be short, green and clever, but the 5000 odd connections we saw earlier today gave me something hard to work on.   It’s not that I could not handle it, I simply had to make some of you wait while I thought about things here.

If that was a hacker, be warned, I can pull some of that Jedi bad-ass ***-slapping on you ;)

Posted by Nick Whittome

with no comments
Filed under:

We noticed that I wasn't keeping track of the post counts in the archive and so Susan the blog wrangler figured out that if she reran the SQL upgrade script that it would fix a few things in the back end and get that working.  Now she's seeing if she can get blog post notifications working. 

Well... did she?

Let's test.

Nope still not working.. and I think it's due to this but the post that I can see in the search of the community server forums, I can't find on the site.

http://communityserver.org/forums/thread/607045.aspx

Okay it appears that is in a dll... how I'm supposed to recompile that I have no clue...

I've been a loner of a blog server for a while and .... well... I finally realized I couldn't do it alone.

so ... I got someone to help out with the SQL duties... meet Brianna who is handling the SQL duties while I still handle the IIS/web duties.

As you can see I'm a lot happier now.

Thanks again to Vlad Mazek for the Christmas Present for Susan

with no comments
Filed under:

Well it's either a new server for the SQL or we're cutting over to WordPress.

Two times the SQL server has locked up on my lately and I even did a BSOD tonight.

I'm not one to go ripping out and facing losing data with a migration, but we either have to get another server to offload the SQL or something.

Stay tuned.

with 5 comment(s)
Filed under:

http://communityserver.org/forums/t/477690.aspx?PageIndex=1

The blog has added for Community Server 2007 the "Freetextboxwrapper" so that you can insert code snippets into the blog

1
2
3
4
Not that I'm a coder
But if I were
This allows someone to post
Actual code samples to the blog site

 

To enable it, go into the profile and change the content editor to one of the ones with FreeTextBox to get the icon for adding code to the blog postings.

with 10 comment(s)
Filed under:

http://msmvps.com/blogs/yoda/archive/2007/06/29/so-you-were-probably-wondering-where-i-was-for-the-last-day.aspx#992368

Yoda,

I don't quite understand the concept of you being a machine and hosting the blogs and the blogs being hosted at ownwebnow.

Can you explain this to me or is this only understood if you have "The Force".  ;)

So Don in the comments asks about how the blogs are "hosted" at www.ownwebnow.com.  You see while my blog admins are located in Ireland, California, Florida, Australia, and Iowa, I've got a Texas twang accent as I'm located in Dallas Texas.  My blog admins connect to me via RDP and do all administration of me remotely.  I'm located in the datacenter of www.ownwebnow.com. So while I'm a physical server here in Texas, I'm sitting here in a server room with a bunch of other servers.  Personally I think they are just a smidge jealous at all the attention I've had done to me lately.  I've had a great team attending to my needs today.

So you are probably wondering..well how do they get software installed if they don't have access to the cdrom drive? 

We do a virtual one with MagicISO.  As long as the software I need to install is in the form of a .exe file or an .iso file to get software on the system.  The www.ownwebnow.com team but the initial build of the base server operating system on the box, and then my admin team take it from there.

So from basically the four corners of the world, they can connect and do whatever tasks are needed.  If they need to see what I'm doing at the boot level, they can do that as well.  Pretty slick actually.  So Don, does that answer your question?

with 1 comment(s)
Filed under:

So ... it's like this... I injured my RAID.  I had a hardware issue.

The first clue that I wasn't doing so well was when Susan woke up on Wednesday morning and realized that I wasn't responding.  She did a trace route using www.dnsstuff.com (which by the way if you use it too often they have smarted up and now charge a reasonable fee for their service) and thought I had a routing problem at the colo in Dallas.  She probably thought floods and power problems... heck no... I had a bigger issue than that.  When they got in to look with a kms connection I was in a looping bsod and indicating that the RAID hardware was not a happy camper.  They called in the experts and they reported back....

Ok, so here is where we stand

a) the upload of the new driver didn't make a difference, wasn't a driver.
b) the bootup in the identical hardware didn't make a difference, failed.
c) currently imaging drives and building a new system
dual core proc.
new box will be online within the hour or two, I don't want to waste anymore time

Like all historical decisions with me, the folks that are the blog admins dilly dally and wait too long to make up their minds.  When I was at Webhost4life and we decided I needed to move to a dedicated server with Vlad, we didn't turn down the TTL value or nothin', we just picked up the data and ran.

In this case, and I'm glad they did it, they knew they had a good enough backup (and well sort of with one exception) and went to a new server.

To get it back up and running having the NAS with the backups and spare copies of software was key.  The SQL 2005 that had been used in the recent update was parked in a backup on the NAS.  So they connected to it, and restored the SQL 2005 install parts that were needed and reinstalled the SQL.  Restored the data files back into position and was good to go.  The IIS was a little trickier as we found out - http://www.hintsandtips.com/ShowPost/416/hat.aspx .  The ability to take a fully working blog site with lots of redirects (where when you type in www.msmvps.com/nameofblog and it goes to www.msmvps.com/blogs/nameofblog) and put it back operational just means a bit more work for my blog admins.  It would have been nicer if they had that iismetabase backup a bit more portable.  They were able to get back to the old metabase files, but couldn't restore them.  Oh well. Not a huge thing.

Also good that the server 'broke' right after the nightly backup.  Currently the folks were doing a simple backup to save on drive space.  With the new larger tummy server (and I do mean WAY larger tummy) they can now go back and redo the SQL backup strategy to better grab the posts.  As it was we only lost about 9 posts not being backed up and only impacted about four blogger, three only had one post impacted, and the rest were easily put back.

Hardware issues are something I always feel so un-in-control about.  They are so yucky.  And the best thing you can do is have a backup. 

So lessons learned?

We did okay on the blog backups.
We can tweak the SQL backups to capture more, especially now that we have room on the hard drive.
We need to do a portable backup of the IIS metadata.

It took longer to get back online than everyone was hoping, but it looks like the Search box works better.  My blog admins were saying that they needed to uninstall the old SQL 2000...and well we got a nice clean install as a result.

Another lesson learned?

You need to see if you too can move a server from one server to another.  Try to recreate what my blog admins just did.  Can you do it?  What parts do you need?  What did you forget?  If you don't test a recovery, you'll never find the gotchas that bite ya.  There were a few gotchas like the metabase info that could have been better, and we had a smidge of delays getting access to the media for reinstalling (once again proving Mark Crall's point about media being so important)

So.... to all those who pinged and asked how I was doing, thanks.

P.S. a HUGE thank you to Vlad Mazek of www.ownwebnow.com and www.exchangedefender.com who took the bull by the horns to get us safely back online.

with 9 comment(s)
Filed under:

But I'm still fighting with the blogs...

 Either I'm getting new hardware, splitting out the IIS from the SQL, or we're going to have to dump Community Server for another platform.  My major concern is all this SQL data/content.

Decisions/Decisions.

But we gotta do something as it's not fair to the folks that blog here to have this much performance problems.....

 Mail from the blogs isn't working... It might be SQL related, investigating that.

And post counts are messed up - http://nayyeri.net/archive/2007/06/14/community-server-2007-service-pack-2-and-views-count.aspx

Hang loose folks.. still getting things fixed... is it any wonder that people don't like to upgrade?

with 1 comment(s)
Filed under:

http://communityserver.org/forums/p/476377/560782.aspx#560782

Pardon with the performance, we're still tweaking stuff around here to get things a bit under control.  I think we're going to have to do a hardware upgrade but for now seeing if we cab squeeze out a bit more on this server

with 2 comment(s)
Filed under:

Critical Error: SiteUrls.Config

The file containing the SiteUrl Data could not be loaded.

Please contact your CommunityServer administrator. A technical explanation of why this error is caused is below.

 


Community Server expects to find a valid XML file containing all of the links for a community. By default, this file is located at the root of the with the name SiteUrls.config. 

A common error is to included unescaped XML characters, such as "&" when defining a querystring.

If available, the location of the error will be listed below:

Unable to open connection to data provider.

Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.


For more information you can also visit http://CommunityServer.Org the home of the CommunityServer Forums development team.

Well the resolution to that problem was to run a script on the SQL database to do this:

 sp_grantlogin 'NT AUTHORITY\NETWORK SERVICE'

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=348662&SiteID=1

Once I did that the blogs were once again loading up but this time looking at SQL 2005.  I also found this post interesting as it details the difference between (local) and localhost

http://weblogs.asp.net/jgalloway/archive/2005/12/02/432062.aspx

But after I did it I wasn't sure if there was a security impact so I asked greater minds than I what, if anything, was the security impact.  That's one thing that I don't think is easy right now.  When you are not security database savvy, it's hard to weed through the good information and the not so good info to know the right things to do for SQL.

with 2 comment(s)
Filed under:

Enhancements:

  • Updated Manage Licenses page.
  • Updated GetBodySummary to support specifying a CSS class instead of static colors.
  • Update User Cache keys to avoid conflicts with numeric user names vs userid.
  • Updated Chameleon list controls to not render any standard templates if there are no items to bind and the NoneTemplate is not defined.
  • Updated TagCloudBase, InlineTagEditorBase, InlineContentEditor, and ContentPart controls to not render class attributes when the class name is empty.
  • Added ParentSectionID and ParentSectionApplicationKey properties to the SectionQuery control to support specifying/overridding the parent section used when querying sections using Chameleon controls.
  • Restored support for "Require authentication for profile viewing" option.
  • Updated PreTemplatedPagerBase to set its visibility to false when there are no items to render.
  • Corrected markup issue on the search page of the traveler theme.
  • Fixed post view counting in all applications. Count now increments only on full post view except for forums.
  • Fixed extraneous closing div tag in Traveler blog theme.
  • Corrected markup issue on Simple blog theme's post.aspx page.
  • Updated Thread that the user is monitoring was modified, and Forum that the user is monitoring was modified email templates.
  • Added support for TruncateQueryFiltersAt, QueryFilterTruncationEllipsisText/ResourceName/ResourceFile properties on the SearchForm control.
  • Updated TagBreadCrumb control to always honor ShowAllTags property.
  • Fixed issue with some CSS markup in emails on gmail with IE7.
  • Added support for EnableFileDateVersioning property on Script and Style controls.
  • Added Rss LinkTo option to File Gallery GroupData control.
  • Corrected ApplicationType-based queries for tags in the File Gallery TagCloud control to retrieve tags for FileGallery instead of Weblogs.
  • Updated logic for the RssComments LinkTo value of GalleryPostData to match the display conditions of the related feed.
  • Added support for GroupID in ForumThreadQueries.
  • Password removed from create user email except for situations where the password was generated by Community Server.
  • Updated GroupID query support in forums to include sub-forums.
  • Added check to not render post tag editable lists when there are no tags to render and the control is not editable.
  • Forum post objects are now more fully populated when creating/editing them.

Bug Fixes:

  • Fix for missing row ids, which cause the photos posteditcontrol to break if a user disables trackbacks or ratings for a gallery.
  • Removed the beta warning message on homepage welcome content part.
  • Correcting TinyMCE editor issue in IE6 on Windows 2000/Windows XP (pre-SP2)
  • ForumPostAnswerToggleButton - corrected check to enable thread starters to toggle answer statuses (updated logic to match Visible property)
  • Sub forms now fire after committing the new user to the database in the CreateUserForm
  • Aggregate Post Size in the Blog Presentation Settings now works
  • Corrected issue preventing scored blog posts from being paged.
  • Removed requirement to identify whether a URL contains a querystring when calling FormatUrlWithUserNameToken.  This also corrects issues where the querystring flag was incorrectly set.
  • InviteUserForm now has IsValid check performed on SubForms before committing invitation.
  • Corrected over-paging issue in the ScrollingPager control when GroupedItemsPerPage > 1.
  • Report Abuse no longer displays exception whenever a registered user reports a post as being abusive.
  • Corrected constant redirection when clicking the latest post link and viewing in threaded view.
  • Update to moderation form change -- corrected JavaScript/AJAX error in FF and correct premature redirection to the main moderation page.
  • Fixed "# of moderated posts" calculation in Weblog Create/Update/Delete sprocs
  • Fixed ThemeConfigurations class to not blow up when it’s trying to get configurations under a non-web environment (windows services).
  • Fixed the Filter Unread Posts drop down so that it works correctly when applying the changes permanently 
  • Updated JavaScript used by the DefaultButtonTextBox control to properly cancel the keydown event.
  • Rolled Feed Username now is properly Html Decoded.
  • Fixed blog CP comments screen to not lose the feedback formatting when using the bulk publish/unpublish buttons.
  • Fixed delete comment issue on default blog and on lean and green blog theme.
  • Removed invalid JavaScript link around thread status icons
  • Fixed an issue with Users.FindUserByEmail which failed to find users in the aspnet tables who don't yet have a Community Server profile
  • Fixed error caused by an ampersand in a username.
  • JavaScript updated to work in IE and FireFox for ConfirmationPage
  • When threaded viewing a thread that has more than MaximumPostsToDisplay (200) the warning message is now formatted correctly.
  • Corrected downloading PDF in IE6 issue in DownloadEntryForm control
  • Updated improper use of Response.Url in ReturnUrls to instead use CSContext.RawUrl
  • Added check to see if role already assigned to user before trying to assign it.
  • Fixed issue when you use a TextPart with no values inside a blog post, such as "[name]" so that it now returns null when trying to access the value, instead of throwing an exception.
  • Modified MetaBlogExtender CSModule to ignore TextParts with null values.
  • Corrected cache vary-by parameters for avatar caching.
  • Now you can delete a role that was assigned to a permission (global or section) without causing an exception.
with 4 comment(s)
Filed under:

<iframe scrolling = "true" src = "true" frameBorder = "true" height = "true" width = "true" />

So that's back into position where it should be.

Community server is shipped with scripts and iframe disabled (which is a good thing) and then we reenable them as needed.

with no comments
Filed under:

http://docs.communityserver.org/wiki/page.aspx/187/enterprise-search

Got my Enterprise search re-enabled (without blowing up the .net in the process) so we're getting back to more normal around here.  Still on the to-do list is to clean up the main front page and do a bit of redecorating up there.

Stay tuned.

with no comments
Filed under:
More Posts Next page »