FIX: IE is stuck at the Runonce page and weird squares and circles on taskbar buttons

Today's email says:

"I'm having trouble getting my home page (MSN.com) to open up when I hit my explorer start up button.  I get a strange "run once" reference up in my address bar.  I end up having to type in WWW.msn.com to get the home page to open.  Then, at the bottom of my screen where the websites that are open are typically indicated, I get only the blue explorer "e" icon followed by 9 or do [sic] little square boxes and three dots.  I just installed IE 7 on this Sony Vaio desktop from the MS download site a week or so ago."

Possible causes of the RunOnce problem are:

  1. The Welcome page does not load completely for whatever reason.
  2. Scripting has been disabled (note: blocking ActiveX does not cause this problem)

In such circumstances, the DWORD "RunOnceHasShown" may not be created in the following registry key, or it may not be set to a value of 1.

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\RunOnceHasShown

If your system is stuck at the initial IE7 welcome page, shut down IE, check for the existence of the RunOnceHasShown DWORD and set it to a value of 1.

Also, ensure that the following key is set to 1:

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\RunOnceComplete

and

HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\SearchMigrated

Also make sure you disable anything that may prevent IE from writing to the registry such as anti-malware applications before trying to install IE7:
http://blogs.msdn.com/ie/archive/2006/10/11/IE7-Installation-and-Anti_2D00_Malware-Applications.aspx

Now we shall look at the "9 or do [sic] little square boxes and three dots"

Shut down IE then go to Control Panel, Display Settings and reset your system to an default XP scheme/appearance.

If that doesn't work, try running IE7 in no add-ons mode - does the problem go away? If so, you need to look at what toolbars and other add-ons you have installed, disabling or uninstalling them one at a time until you find the culprit - one that has been reported as being problematic is Stopzilla, a pop-up blocker.

Still no luck?  Check these things:

  1. Tools, Internet Options, Languages button.  Make sure that the correct language is installed.  Eg, if you are in the USA, you should be running "English (United States) [en-us]".
  2. Check your computer's regional settings (Control Panel, Regional Settings)
  3. Check your encoding options (Press the Alt key, then select "View", then "Encoding" on the Menu Bar that will appear).  My systems are set to Unicode (UTF-8) although Western European (Windows) or (ISO) are fine. I try to avoid Auto Select which has been problematic in the past.
  4. Of course, for English speaking countries, "Left-to-right document" should be selected.
  5. RIES sometimes helps with weird symptoms (Tools, Internet Options, Advanced tab - down the bottom).

Now *if* none of the above works, it is possible that there is a corrupt font on the computer in question, but if that is the case I would expect that more areas on the computer may be affected.

Published Thu, May 10 2007 16:53 by sandi

Comments

# re: FIX: IE is stuck at the Runonce page and weird squares and circles on taskbar buttons

Monday, July 09, 2007 5:39 AM by Pete

The "RunOnceHasShown" DWORD was just what the doctor ordered. Man that was annoyoying!

Thanks!