subject: exchange

Rui Silva - Exchanging Knowledge About Exchange

Recent Posts

Tags

News

Disclaimer

  • This posting is provided "AS IS" with no warranties, and confers no rights.
    The opinions expressed herein are my own personal opinions and do not represent my employer's view in anyway. Please use the Exchange Forums for support requests.

Email Notifications

Blogroll

Links

Archives

You cannot resume setup by performing the action "BuildtoBuildUpgrade"

I recently made 2 important decisions regarding my test environment:

  1. Move all the VMs to Hyper-V;
  2. Install Exchange 2007 SP1.

Moving to Hyper-V is not that hard:

  1. Remove the VM Additions;
  2. Create a new Hyper-V VM using the previous VHD.

My problems started when installing Exchange Server 2007 Service Pack 1. After I kicked the SP1 Setup, I got a warning that I should first install .NET Framework 2.0 SP1 (how could I disregard my own recommendations?), so I stopped the setup process.

After installing the required update, I resumed the SP1 setup, but now I got the following error:

Setup previously failed while performing the action "install". You cannot resume setup by performing the action "BuildtoBuildUpgrade"

Microsoft Knowledge Article KB947281 describes this problem and has a resolution for it. Unfortunately the article is a little bit incomplete. It tells you to delete the Watermark and Action entries from any of these Registry keys:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\ClientAccessRole
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\HubTransportRole
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\MailboxRole

But for my particular case the Watermark and Action entries were located at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\UnifiedMessagingRole.

So, the right solution should be to check for those entries at any of these keys:

  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\ClientAccessRole
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\HubTransportRole
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\MailboxRole
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\UnifiedMessagingRole
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Exchange\v8.0\ClusteredMailboxServer
  • [UPDATE]
    The KB Article has been corrected!

    Share it! :

    Comments

    Resume setup | Myequipmentrentals said:

    Pingback from  Resume setup | Myequipmentrentals

    # June 28, 2011 10:59 AM