[There's a reason that Yoda is the unofficial mascot of SBS.  Size indeed matters not.] Getting OWA lite when using IE 11? - THE OFFICIAL BLOG OF THE SBS DIVA
Sat, Dec 7 2013 22:32 bradley

Getting OWA lite when using IE 11?

So you installed IE11 and suddenly OWA keeps wanting to use OWA lite when you access Exchange 2010 or 2013 right?

It's due to timing of updates... these Exchange updates aren't yet on MU or WSUS (and actually the 2013 version won't be on MU or WSUS you have to manually install it)

Released: Exchange Server 2013 Cumulative Update 3 - Exchange Team Blog - Site Home - TechNet Blogs:
http://blogs.technet.com/b/exchange/archive/2013/11/25/released-exchange-server-2013-cumulative-update-3.aspx
http://support.microsoft.com/kb/2892464

which includes 2866064(http://support.microsoft.com/kb/2866064/ ) Can't load OWA Premium by using Internet Explorer 11 in an Exchange Server environment

and http://blogs.technet.com/b/exchange/archive/2013/11/25/released-update-rollup-3-for-exchange-2010-service-pack-3.aspx 

http://support.microsoft.com/kb/2891587 which also includes  - 2866064 (http://support.microsoft.com/kb/2866064/ ) Can't load OWA Premium by using Internet Explorer 11 in an Exchange Server environment

Filed under:

# re: Getting OWA lite when using IE 11?

Sunday, December 08, 2013 1:22 AM by Active IT Design

Workaround for now, hit F12, choose IE10 mode, browser will refresh the login page and now the box to uncheck OWA lite can be unchecked.

# re: Getting OWA lite when using IE 11?

Sunday, December 08, 2013 2:46 PM by Active IT Design

Easy workaround for now is to hit F12 on the login page, switch to IE 10 mode, the page will refresh, and then you can uncheck the box that says to use OWA Lite.

# re: Getting OWA lite when using IE 11?

Monday, December 09, 2013 6:49 AM by Pete P

Don't forget you have to install the update rollup from a command prompt as administrator.