Tue, Mar 24 2009 12:31 Ben Walters

SharePoint 503 Service Unavailable Error

For the last couple of days I’ve been doing some work on a SharePoint event handler which was progressing at a good rate until I started getting a “503 Service unavailable” error after deploying an update.

After some searching it turned out that when WSP builder deployed the update for my Event Handler the App Pools for the SharePoint site failed to start. After restarting these from IIS manager all was good. Not sure exactly why the App Pools decided they didn’t want to come back up as I couldn’t spot any issues in the event logs on the server, but all is well now.

Filed under: ,

# re: SharePoint 503 Service Unavailable Error

Monday, March 23, 2009 10:03 PM by Brian Farnhill

I find this happens when you deploy two WSP files in quick succession sometimes, but even then its not 100% consistent

# re: SharePoint 503 Service Unavailable Error

Friday, July 03, 2009 1:17 PM by Mohamed Hachem

503 is most of the time related to the app pool you may have changed identity password also make sure you can access the administration console

# re: SharePoint 503 Service Unavailable Error

Wednesday, July 08, 2009 7:53 AM by Clark

Yep, bit by this too.  And I didn't pick up that the App Pools weren't actually running until I read this post--so thanks.  Guess I need to pay more attention to those IIS Manager app pool icons next time.

Leave a Comment

(required) 
(required) 
(optional)
(required) 
If you can't read this number refresh your screen
Enter the numbers above: